Get in touch
Back
Maintenance

System Upgrade

Completed 12 Jan at 10:00pm GMT.

komi.io
Completed

Maintenance completed

Posted 12 Jan at 10:00pm GMT.
Started

Urgent system upgrade is being conducted.

Posted 12 Jan at 09:00pm GMT.